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Contacting Us 

There are several ways to contact Thermo Fisher Scientific for the 
information you need.  

To contact Technical Support 

Email support.informatics@thermofisher.com  

Web http://support.thermoinformatics.com/contact 

To contact Customer Service for ordering information 

Web http://www.thermoscientific.com/informatics 

To suggest changes or provide feedback on the documentation 

Send an e-mail message to the Informatics Documentation 
Manager:  

sidinf.documentation@thermofisher.com 

mailto:support.informatics@thermofisher.com
http://support.thermoinformatics.com/contact
http://www.thermoscientific.com/informatics
mailto:sidinf.documentation@thermofisher.com
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1. Welcome to GRAMS 
Envision 

GRAMS Envision is a multi-format instrument data viewer with 
the capacity to host plug-in processing and reporting modules. 

GRAMS Envision (hereafter referred to as Envision), enhances 
GRAMS Smart Convert technology to support the GAML 
(Generalized Analytical Markup Language) open standard XML 
instrument data format. This format allows capture of 
comprehensive metadata and simplifies communication with an 
increasing number of third-party products. For more details 
about GAML, see the GAML Web site: 

http://www.gaml.org 

Designed to provide simple integration with external systems, 
Envision benefits from the Microsoft .NET development 
environment, using easily configurable menus, flexible screen 
architecture, and an extensible modular design.  

Posting data to the other products of the GRAMS Suite is 
achieved through basic mouse and menu options.  

The integral Web browser allows seamless connectivity with 
enterprise data management portals and Web-based search tools. 
A comprehensive command line interface and enhanced Paste 
Special function allows simple interaction with desktop 
applications and electronic lab notebooks. 

Envision can use report methods created using the XML-based 
Blaise Inform design tool. Inform provides a comprehensive 
visual reporting tool for GRAMS Suite data and allows users to 
apply standardized reports to data originating from multiple 
instrument vendors.  

This manual guides you through the use of Envision. 

http://www.gaml.org/
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Envision is supplied with a comprehensive set of instrument data 
file converters (the GRAMS converters) that can translate a wide 
range of instrument data into the standard GAML format. 
Supported data types include industry-standard formats (such as 
ASCII and AnDI/netCDF) as well as vendor-specific formats (for 
example, Thermo Scientific Atlas CDS and Agilent 
ChemStation). 

File conversion is triggered by opening a data file in Envision. 
Smart Convert logic identifies the file format and selects the 
correct file converter. 

You must install the file converter package separately from the 
Envision application itself. For more details, see “Installing the 
GRAMS Converters” in the GRAMS Envision Installation Guide. 

Once the file converters are installed, you can find more 
information about them in the Instrument Data File Converters 
Help. To access this help system, select Instrument Help from the 
Envision Main menu’s Help menu. 

Note The list of file converters available on your system 
depends on the type of license that you have purchased. ▲ 

In addition to the formats handled by the file converters, 
Envision can read data in Agilent’s Analytical Instrument Markup 
Language (AnIML) format. 

Instrument Data File 
Converters 

Agilent AnIML 
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To start Envision on a typical system: 

1. From the Windows Start menu, select  
All Programs > Thermo GRAMS Suite > Envision  

2. The next step depends on whether Envision has been set up 
with a valid license: 

• A valid license has been installed. 

The Envision application opens.  

• A valid license cannot be found. 

A License Failure message appears: 

 

Figure 1-1. License Failure message 

• Click OK to view instructions on obtaining an 
Envision license. 

The Request License window appears, from which 
you can request a license. For more details about 
licensing, see the Licensing Envision chapter of the 
GRAMS Envision Installation Guide. 

After you request a license, Envision opens in Demo 
Mode. 

• Click Cancel to skip licensing instructions. 

Envision opens in Demo Mode. 

Starting Envision 
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When Envision cannot find a valid license, it starts in Demo 
Mode. The HTML Viewer opens (as the default module) with 
the GAML Web site’s “Example GAML files” page loaded: 

 

Figure 1-2. Envision in Demo Mode 

From this Web page you can download example GAML files 
derived from a range of common instruments, which you can 
then view in Envision. 

When operating in Demo Mode, Envision only opens GAML, 
SPC, and AnIML data files, and it does not save GAML data 
files. All the standard display capabilities remain available. 

 

Demo Mode 
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2. The Envision User Interface 

The Envision user interface contains these features:  

Main toolbar Main window

Main menu 

LegendWorkspace

Data Preview 
window

File Navigator

Status bar
 

Figure 2-1.  Envision User Interface 

Feature Description 

Main 
menu 

Provides access to Envision functions. For 
example, changing how items appear in the 
interface or accessing the Envision Help.  

See the Menus section for more details. 
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Feature Description 

Toolbars Provide quick access to main Envision functions.  

See the Toolbars section for more details. 

File 
Navigator 

Shows all open GAML files. Items within the 
files appear in a tree hierarchy format. 

See the File Navigator section for more details. 

Data 
Preview 
window 

Provides a thumbnail view of the selected data 
element.  

See the Data Preview Window section for more 
details. 

Main 
window 

At startup, contains the Trace Browser, 
Parameter Browser and Peak Table Browser 
modules. Each of these modules updates when 
you change the selection in the File Navigator.  

See the Main Window section for more details. 

Legend Indicates the line style of the spectra currently 
on display.  

See the Trace Browser section for more details. 

Workspace Contains a listing of all working data and data 
held for future use in the Holding Area.  

See the Workspace Pane section for more details. 

Status bar Shows the path of the currently active data item 
within its GAML file. This matches the 
description for that item in the Workspace pane.  

See the Status Bar section for more details. 
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The Envision interface contains two menu bars: 

• Main menu (at the top of the overall Envision window) 

This section describes the options in this menu. 

• Main Window menu (at the top of the Main Window) 

This menu changes according to the selected view. See the 
Main Window Menu section. 

The Envision Main menu appears at the top of the Envision 
window. This menu allows you to open files, open additional 
tabs, hide tabs, modify toolbars and display options, and forward 
data to other GRAMS Suite applications. 

The Main menu contains the following submenus: 

 

Figure 2-2.  Envision Main menu 

Menus 

Main Menu 
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The File menu contains the following options: 

 

Figure 2-3.  File menu 

Option Description 

Open Allows you to open a file using a standard 
Open window. 

This option uses Envision’s SmartConvert 
technology to try to identify the instrument 
the data file is from. If it cannot find it 
automatically, use the option “Import (by 
Instrument Type).” 

If you are running Envision on Windows 
Vista or later, you can preview data files 
within the Open window.  

See the Previewing Data Files section. 

Import (by 
Instrument 
Type) 

If you know what instrument produced your 
data, you can import data files using this 
option. 

See the Using the Import (by Instrument 
Type) Option section. 

Open HTML 
Viewer 

Opens a new HTML Viewer in the Main 
window. 

See the HTML Viewer section. 

File Menu 
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Option Description 

Save As Save a GAML file. This option is only 
available if you have first selected a top level 
or parent node in the File Navigator or 
Workspace. 

See the Using the Save As Option section. 

Close Closes the currently active GAML file. 

Close All Closes all open GAML files. 

Exit Closes the Envision application. 

Previewing Data Files 

In Windows Vista or later, you can preview data files in any 
Windows Explorer window. 

For example, the following screenshot shows the Windows 7 
version of the Open window (accessed from Envision’s File 
menu), using Large Icons display and the Preview pane: 

 

Figure 2-4.  Open window showing thumbnail previews and Preview pane 



The Envision User Interface 

10      GRAMS Envision User Guide Thermo Fisher Scientific 

Buttons at the top right of the window control the preview 
functionality: 

• Click  to change the icon view. Options larger than 
Medium Icons show thumbnail previews of each data file. 

• Click  to show a Preview pane, to the right of the Open 
window. You can: 

• Click on a point within the Preview pane to highlight its 
coordinates. 

• Click and drag to select an area, and then click within 
that area to zoom into it. 

Using the Import (by Instrument Type) Option 

If you know what instrument produced your data, you can 
import data files using the File menu’s “Import (by Instrument 
Type)” option. 

To import a file: 

1. Select File > Import (by Instrument Type) from the Main 
menu. 

A window appears that lists all the instruments supported by 
Envision:  

 

Figure 2-5.  Import File window 
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The Instrument Help button opens the Instrument Data File 
Converters Help.  

Note If your copy of Envision is not licensed for data 
conversion, an error appears when you try to use this option. 
▲ 

2. Locate your instrument in the list, and then click Next. 

You can enter the name, or part of the name of the 
instrument in the Filter List field to aid in finding the 
instrument. For example, entering “chrom” in the Filter List 
field shortens the list to only those instruments with names 
that contain that string.  

The Reset button clears any filters and restores the full 
instrument list. 

Note Instrument names that have “[Database]” appended 
to them require you to log on to a database after you click 
Next. For information on these converters, see the Instrument 
Data File Converters Help. ▲ 

3. The standard Open window appears. Select your data file and 
click Open. 

4. Envision imports the data file and shows its first data trace in 
the Trace Browser. 
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Using the Save As Option 

You can use the Save As menu option to: 

• Save entire GAML files to new locations or with new file 
names. 

• Save GAML files’ sub-nodes (that is, items containing traces 
or trace arrays) as SPC format binary files. 

Note The SPC format does not fully support GAML peak 
tables so, when saving GAML data to SPC format, any peak 
tables are lost. When you open the resulting SPC files in 
Envision, the File Navigator and Trace Browser will not show 
any peak names. ▲ 

When you select this option, a standard Save As window appears 
for you to enter a file name and location. 

If the Save As feature is enabled for GAML files on your system, 
the Save As menu option is enabled when you select the top level 
(GAML file) node in the File Navigator or the Workspace. 

Note The ability to save GAML files is a separately licensed 
feature of Envision, which can be obtained by contacting Thermo 
Fisher Scientific Sales: 

sales@gramssuite.com ▲ 

mailto:sales@gramssuite.com
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The View menu contains the following options: 

 

Figure 2-6.  View menu 

Option Description 

Trace Browser Shows or hides the Trace Browser. 

See the Trace Browser section. 

Parameter 
Browser 

Shows or hides the Parameter Browser. 

See the Parameter Browser section.  

Peak Table 
Browser 

Shows or hides the Peak Table Browser. 

See the Peak Table Browser section. 

Trace Preview When selected, the Data Preview window 
shows the active element’s trace. 

See the Data Preview Window section. 

Property 
Preview 

When selected, the Data Preview window 
shows the active element’s properties.  

See the Data Preview Window section. 

View Menu 
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Option Description 

Hide Preview Hides the Data Preview window.  

A check mark appears beside this option if 
the Data Preview window is currently 
hidden. 

See the Data Preview Window section. 

Standard 
Toolbar 

Shows or hides the Standard toolbar.  

See the Standard Toolbar section. 

Operations 
Toolbar 

Shows or hides the Operations toolbar.  

See the Operations Toolbar section. 

Workspace Shows or hides the Workspace pane. 

See the Workspace Pane section. 

Status Bar Shows or hides the status bar.  

See the Status Bar section. 

File Navigator Shows or hides the File Navigator. 

See the File Navigator section. 
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The Display menu contains the following options: 

 

Figure 2-7.  Display menu 

Option Description 

New Trace 
Viewer 

Opens a new instance of the Trace Viewer in 
the Main window. 

New 
Parameter 
Viewer 

Opens a new instance of the Parameter 
Viewer in the Main window. 

New Peak 
Table Viewer 

Opens a new instance of the Peak Table 
Viewer in the Main window. 

New Link 
Viewer 

Opens a new instance of the Linked Data 
Viewer in the Main window. 

GAML 3D 
Viewer 

Opens a new instance of the GAML 3D 
Viewer in the Main window. 

The Report menu contains the Browse Report Method option. 
This option accesses the Report Viewer, where you can create 
reports from GAML data. 

See the Report Viewer section. 

Display Menu 

Report Menu 
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The Action menu contains the following options: 

 

Figure 2-8.  Action menu 

Use these options to send the active trace array or entire trace to 
the following applications: 

• GRAMS/AI 

• GRAMS/3D 

• Spectral ID  

Note If a product is not installed, an error message appears 
when you choose the corresponding option. ▲ 

Envision exports the data to SPC format, and opens it in the 
specified application: 

• If the data is a trace with multiple trace arrays, a multifile is 
sent to GRAMS/AI or Spectral ID. If the data is a trace array, 
the single trace array is sent to GRAMS/AI or Spectral ID. 

• When sending data to GRAMS/3D, the entire trace 
(multifile) is sent regardless of whether the current element is 
a trace or trace array. 

Action Menu 
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The Tools menu contains an option for accessing the Options 
window, where you can set a number of program options. 

See the Setting Envision Options section. 

The Window menu contains options to control how browsers 
and viewers appear in the Main window: 

 

Figure 2-9.  Window menu 

Option Description 

Tabbed View Displays open viewers and browsers as 
separate tabbed pages. 

This is the default view, as indicated by a 
check mark. When disabled, open viewers 
and browsers are shown as separate windows, 
which can then be cascaded or tiled. 

Cascade Displays open viewers and browsers using a 
cascaded arrangement. This option is only 
available when Tabbed View is disabled. 

Tile 
Horizontally 

Displays open viewers and browsers using a 
horizontally tiled arrangement. This option 
is only available when Tabbed View is 
disabled. 

Tools Menu 

Window Menu 
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Option Description 

Tile Vertically Displays open viewers and browsers using a 
vertically tiled arrangement. This option is 
only available when Tabbed View is 
disabled. 

Close Current 
Window 

Closes the currently active viewer or browser. 

Close All 
Windows 

Closes all viewers and browsers. 

The bottom of the Window menu contains a list of the viewers 
and browsers that are currently open. Select an item from the list 
to make it the active window. 

The Help menu contains the following options: 

Option Description 

GRAMS 
Envision Help 

Opens the Envision Help. 

Instrument 
Help 

Opens the Instrument Data File Converters 
Help. This option only works if the 
GRAMS Converters Package is installed on 
your system. 

About GRAMS 
Envision 

Displays the installed version and licensing 
details for Envision. 

This option also allows you to select 
another license, or request a new license.  

For more details on licensing, see the 
chapter Licensing Envision chapter of the 
GRAMS Envision Installation Guide. 

Help Menu 
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The Envision user interface includes the following toolbars: 

• Standard toolbar 

• Operations toolbar 

• Browser toolbars 

This section includes descriptions of the Standard and Operations 
toolbars, as well as how to add or remove toolbar buttons. 

For descriptions of the individual browser toolbars, see the Trace 
Browser, Parameter Browser and Peak Table Browser sections. 

The Standard toolbar contains the following buttons by default: 

Button Description 

 Open File Opens a GAML or SPC file. 

 Open New 
HTML 
Viewer 

Opens a new HTML Viewer window. 

See the HTML Viewer section. 

 Save As Save the selected GAML file. This 
button is only active if you have first 
selected a top-level or parent node in 
the File Navigator or Workspace. 

See the Using the Save As Option 
section. 

 Close 
Current File 

Closes the currently active GAML file. 

 Close All 
Files 

Closes all open GAML files. 

Toolbars 

Standard Toolbar 
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The Operations toolbar contains the following buttons: 

Button Description 

 Open in new 
Trace Viewer 
window 

Opens a new instance of the Trace 
Viewer.  

See the Trace Browser section. 

 Open in new 
Parameter 
viewer 
window 

Opens a new instance of the Parameter 
Viewer.  

See the Parameter Browser section. 

 Open in new 
Peak Table 
viewer 
window 

Opens a new instance of the Peak 
Table Viewer. 

See the Peak Table Browser section. 

 Open in new 
Link viewer 
window 

Opens a new instance of the Linked 
Data Viewer. 

See the Linked Data Viewer section. 

 Send Data to 
GRAMS/AI 

Sends the current trace or trace array to 
GRAMS/AI (as an SPC file). 

 Send Data to 
GRAMS/3D 

Sends the current trace to GRAMS/3D 
(as an SPC file). 

 Send Data to 
Spectral ID 

Sends the current trace or trace array to 
Spectral ID (as an SPC file). 

 Options Opens the Options window, in which 
you can set a number of program 
options.  

See the Customizing the User Interface 
section. 

 GRAMS 
Envision 
Help 

Opens the Envision Help. 

Operations Toolbar 



 The Envision User Interface 

Thermo Fisher Scientific GRAMS Envision User Guide      21 

You can customize the Envision toolbars by adding or removing 
toolbar buttons.  

To add or remove toolbar buttons: 

1. On the toolbar you want to modify, click  and choose Add 
or Remove Buttons. 

A list appears, containing the default buttons for that toolbar. 
Buttons currently shown on the toolbar have check marks: 

 

Figure 2-10.  Add or Remove Buttons options 

2. Click a button name to toggle its inclusion on the toolbar. 
The button is added or removed immediately. 

3. If you need to edit the toolbars further, click Customize to 
open the Customize window: 

 

Figure 2-11.  Customize window 

Adding or Removing 
Toolbar Buttons 
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The tabs on this window allow you to: 

• Add, rename or delete entire toolbars. 

• Drag menu options (commands) on to or out of toolbars. 

• Specify toolbar and menu options across Envision. 
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The status bar appears at the bottom of the Envision interface. It 
shows the path of the currently active data item within its GAML 
file. This matches the description for that item in the Workspace 
pane.  

 

Figure 2-12.  Status Bar 

To toggle the status bar on or off, select View > Status Bar from 
the main menu. 

The status bar indicates whether the Parameter Viewer is in Filter 
or Browse mode by listing the number of parameters displayed as 
X of Y rows. 

Status Bar 



The Envision User Interface 

24      GRAMS Envision User Guide Thermo Fisher Scientific 

The File Navigator appears at the left side of the Envision user 
interface. All open files appear here for ease of navigation and 
access. 

The File Navigator uses a tree view to represent each level of the 
GAML hierarchy. Each level in the hierarchy has a unique icon 
associated with it and indicates if the data is linked. 

 

Figure 2-13.  File Navigator 

You can pin, unpin, resize or close the File Navigator. See the 
Customizing the User Interface section. 

Click the Expand or Collapse buttons   at each level to 
expand or collapse the tree, or double-click an element that has 
child elements to toggle its expansion.  

You can also use the arrow keys to navigate through the tree. 

When you click on an element, that element becomes active. 
Browsers in the Main window update to reflect the relevant data 
for the element, and its details appear in the status bar. For an 
introduction to the browsers, see the Main Window section. 

File Navigator 
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The following icons represent elements in the File Navigator 
pane: 

Icon Description 

 Root node of 
GAML file 

This node is always present. The 
Parameter Browser shows information 
associated with the entire file. The root 
node always contains at least one 
experiment node. 

 Experiment 
node 

A single analyzed item containing at 
least one trace node. The Parameter 
Browser shows information associated 
with the selected item. 

 Trace node Data taken from a single detector or 
from several sources is indicated by a 
single or multiple traces for the 
experiment. The Parameter Browser 
shows information associated with the 
data. 

 Trace array 
node 

Represents a single 2D X,Y profile. 

 Peak table 
node 

Acts as the parent for the individual 
peaks in a trace array. Displays as a 
child to the trace array and can contain 
more than one peak. The Peak Table 
Browser shows information about each 
identifiable peak in the trace array. 

 Peak node Represents an individual peak in a 
trace array. The Parameter Browser 
shows information associated with the 
peak. 

 Linked view 
node 

A 3D display available when data 
produced by an instrument and the 
converter create a link between the two 
trace array types. 

Viewing the File 
Navigator Hierarchy 



The Envision User Interface 

26      GRAMS Envision User Guide Thermo Fisher Scientific 

When you right-click an item in the File Navigator, a shortcut 
menu appears that contains many of the options available in the 
Main menu: 

 

Figure 2-14.  File Navigator menu 

The Send to Holding Area option is unique to this menu. For 
information on this feature, see the Holding Area section. 

File Navigator Shortcut 
Menu 
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The Data Preview window appears below the File Navigator: 

 

Figure 2-15.  File Navigator with Data Preview window 

The Data Preview window provides a preview of the item that is 
currently selected in the File Navigator pane.  

Information can be viewed in two ways: 

• Trace Preview (default) 

• Property Preview 

To change the display mode, you can: 

• Right-click the Data Preview window and choose a viewing 
option from the shortcut menu. A check mark indicates the 
current mode. 

Data Preview 
Window 



The Envision User Interface 

28      GRAMS Envision User Guide Thermo Fisher Scientific 

• Choose View from the Main menu, and then choose a 
viewing option. A check mark indicates the current mode.   

The Trace Preview shows the active element: 

 

Figure 2-16.  Trace Preview mode 

The information in the Trace Preview depends on the item that is 
currently selected in the File Navigator: 

• When a GAML file or experiment is selected, the Data 
Preview window contains the message “<Preview not 
available>.” 

• When a trace is selected, the Data Preview window contains 
the first trace of the trace array. 

• When a trace array is selected, the Data Preview window 
contains the trace array data as a 2D trace (either continuous 
or discrete pulses). 

• When a peak table is selected, the display window contains 
the peak table’s trace array data as a 2D trace. The peak is 
labeled as it is in the File Navigator. 

• When a peak is selected, the display window shows the peak’s 
trace array data as a 2D trace. Only that peak is displayed and 
is labeled as it is in the File Navigator. 

• When a linked view is selected, the display window shows the 
parent trace data as a 2D trace (either continuous or discrete 
pulses). 

Trace Preview Display 
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The Property Preview shows the properties of the item that is 
currently selected in the File Navigator: 

 

Figure 2-17.  Property Preview mode 

Information can include the specific values of elements and 
attributes, as well as some derived properties. The information 
differs according to the element type. If an element, attribute, or 
other property does not apply, it is not displayed. 

Note You can also view this information when viewing the 
Parameter Browser by selecting File > Element Properties from 
the Main menu. See the Parameter Browser section. ▲ 

To hide the Data Preview window, you can: 

• Right-click the Data Preview window and select Hide 
Preview from the shortcut menu.  

• Select View > Hide Preview from the Main menu.   

To redisplay the Data Preview window, select a preview mode 
from the View menu. 

Property Preview Display 

Hiding the Data Preview 
Window 
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The Main window contains pages that allow you to view, approve 
and report data. These pages fall into two categories: 

• Browsers 

These update each time you select new GAML data in the 
File Navigator. 

• Viewers 

These only update when you “send” new GAML data to 
them. See the Sending Data to a Viewer section. 

When Envision opens, the Main window contains three browsers: 

• Trace Browser 

This is a modified version of the Trace Viewer that contains 
the trace of the item selected in the File Navigator. This 
window cannot contain more than one trace.  

See the Trace Browser section. 

• Parameter Browser 

This is a modified version of the Parameter Viewer that 
contains the parameters, derived properties, and element and 
attribute values of the selected item in the File Navigator.  

See the Parameter Browser section. 

• Peak Table Browser 

This is a modified version of the Peak Table Viewer that 
contains peak table elements and attributes as well as peak 
parameters of the selected item in the File Navigator.   

See the Peak Table Browser section. 

You can use the navigation icons  in the top right corner of 
the Main window to navigate through the tabs or close views. 

Main Window  
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You can view a list of all windows that are currently open in the 
Main window by choosing Window from the Main menu. Open 
windows are listed at the bottom of the Window menu: 

 

Figure 2-18.  Window menu with example list of open windows 

Open browsers appear at the top of the list. Open viewers are 
suffixed with a number indicating the order in which they were 
opened. 

Note An exception is the HTML Viewer, where the initial view 
opens without a numeric suffix. Subsequent HTML Viewers 
open with numeric suffix. ▲ 

Selecting an item from this list changes the display in the Main 
window to the selected view. 

Individual tabs can be closed or opened by choosing View from 
the Main menu, then selecting or clearing the item of interest. 
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There are several viewing modes for the Main window: 

• Tabbed View – The default view for the Main window. Click 
on a tab to make the corresponding module active and bring 
it into focus. 

• Cascade – Arranges the windows in a cascading, stacked view. 

• Tile Horizontally – Arranges the windows in a horizontal 
array. 

• Tile Vertically – Arranges the windows in a vertical array. 

Note If Tabbed View is enabled, all other viewing options are 
disabled. ▲ 

When in Tabbed View mode, click one of the tabs in the Main 
window to bring that item to the foreground.  

To close a window in Tabbed View mode, click a window’s tab 
to make sure it is the current window, and then click the close 
button  in the top-right corner of the Main window. 

To change the display mode: 

1. Choose Window from the Main menu. 

2. Select a display mode from the Window menu. 

Viewing Modes 

Changing the Display Mode 
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There are several ways to send GAML data to one of Envision’s 
viewer panes: 

• Select an element in the File Navigator, and then choose one 
of the Display menu’s New Viewer options. 

• Select an element in the File Navigator, and then click one of 
the Operations toolbar’s “Open in new viewer” buttons. 

• Open a viewer pane, and then drag an element from the File 
Navigator into it. 

• Right-click an element in the File Navigator, and then select 
an open viewer from the shortcut menu.  

In each case, data can only be sent to a viewer that supports that 
type of data. For example, when you select an injection, the 
Display menu’s New Trace Viewer option is unavailable. 

The Main Window menu options appear across the top of the 
Main window. The functions in this menu are specific to the 
currently selected browser or viewer. 

For example, the Trace Browser has the following options on its 
Main Window menu: 

 

Figure 2-19.  Main Window menu for the Trace Browser 

For descriptions of the available functions, see the individual 
browser and viewer sections of this chapter. 

The toolbar at the top of the Main window is specific to the 
currently selected browser or viewer. For descriptions of the 
available functions, see the individual browser and viewer sections 
of this chapter. 

Sending Data to a Viewer 

Main Window Menu 

Main Window Toolbar 
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The Trace Browser is a viewing window that displays 2D views of 
a trace. It appears when you open a new GAML file, and is also 
available from the shortcut menu for Trace and Trace Array 
elements in the File Navigator. 

The Trace Viewer is an extended version of the Trace Browser, 
including functionality for showing multiple traces. 

 

Figure 2-20.  Trace Browser  

The functionality described in this section, while labeled for the 
Trace Browser, also applies to the Trace Viewer. Any differences 
between the two are highlighted. 

The Legend is located below the Trace Browser pane. It describes 
all trace arrays that are currently loaded. As long as there is a trace 
array in use, there will always be one and only one active trace 
array.  

You can right-click a trace array in the Legend to open a menu of 
functions for selecting and manipulating traces. 

Note The Legend can be pinned, unpinned, resized or closed as 
needed. See the Customizing the User Interface section. ▲ 

Trace Browser and 
Viewer 

Legend 
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This section describes the menu options at the top of the Trace 
Browser and Trace Viewer panes. 

The File menu for the Trace Browser contains the following 
options: 

 

Figure 2-21.  Trace Browser – File menu 

Option Description 

Remove 
Current Trace 

Removes the selected trace from the Trace 
Browser pane and the Legend. 

This option is designed for the Trace 
Viewer, which can show multiple traces. 

Remove All 
Traces 

Removes all traces from the Trace Browser 
pane and the Legend. 

Page Setup Opens a standard Page Setup dialog box, 
which allows you to adjust page settings 
prior to printing.  

Print Preview Opens a standard Print Preview pane, which 
allows you to preview a trace prior to 
printing. 

Print Sends the current trace to the printer. A 
standard Print dialog box appears, from 
which you can select the printer. 

Close Closes the Trace Browser. 

Trace Browser Menus 

File Menu  
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The Edit menu for the Trace Browser contains the following 
options: 

 

Figure 2-22.  Trace Browser – Edit menu 

Option Description 

Undo Last 
Zoom 

Undoes the last zoom or autoscale operation. 

Copy Copies the currently selected data to the 
clipboard. 

The View menu for the Trace Browser contains standard options 
to hide or display toolbars and the Legend pane: 

 

Figure 2-23.  Trace Browser – View menu 

Edit Menu 

View Menu 
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The Display menu for the Trace Browser contains the following 
options: 

 

Figure 2-24.  Trace Browser – Display menu 

Note The Zoom and Autoscale features affect the display of all 
loaded data if the display is set to either the Stacked or Overlaid 
mode. ▲ 

Option Description 

Autoscale Rescales the display such that the data points 
and peak labels fit into the display 
completely. 

Autoscale – X 
only 

Rescales the display such that the x-axis fits 
into the display completely. 

Autoscale – Y 
only 

Rescales the display such that the y-axis and 
peak labels fit into the display completely. 

Zoom In Rescales the display to zoom in 10% around 
the current position of the crosshairs 
(whether or not they are actually visible). 

Zoom Out Rescales the display to zoom out 10% 
around the current position of the crosshairs 
(whether or not they are actually visible). 

Display Menu 
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Option Description 

Set Display 
Limits 

Opens the Set Limits dialog box, in which 
you can specify the display limits for the X 
and Y axes. 

See the Setting the Trace Display Limits 
section. 

Display Mode Selects the display mode.  

This option is designed for the Trace 
Viewer, which can show multiple traces. 

The following options are available: 

• Paged – Shows only one trace array in 
the Trace Viewer. 

• Overlaid – Overlays all open trace arrays 
in the Trace Viewer. 

• Stacked – Shows all open trace arrays 
stacked in the Trace Viewer. 

See the Viewing Multiple Traces in a 
Window section. 

Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. By 
default, all low values display to the left, with 
high values to the right.  

Normalize Y Normalizes the Y data points from 0 to 1. 

When you select this option, a warning 
message appears to advise you that peak label 
information cannot be shown in normalized 
display. If you choose to continue, peak 
labeling is turned off. 
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Option Description 

Peak Labels Opens a menu with the following options: 

 

Figure 2-25.  Peak Labels menu 

Choose an option to change the peak labels. 
The default option labels peaks using the 
same text as their elements in the File 
Navigator. 

See the Trace View Peak Labeling section. 

Active Trace Opens a menu with the following options: 

 

Figure 2-26.  Active Trace menu 

You can use the options on this menu to 
navigate to another data point, change the 
properties of the active trace, or add user-
defined labels to the active trace. 
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The Tools menu for the Trace Browser contains the following 
options: 

 

Figure 2-27.  Trace Viewer – Tools menu 

Option Description 

Options Opens the Trace Viewer Options window.  

See the Setting the Trace Display Options 
section. 

Unit Display 
Configuration 

Use this option to change the units of data 
so that multiple traces can be compared on 
the same unit scale. 

This option is only available in the Trace 
Viewer, which can show multiple traces.  

See the Applying Unit Conversions for 
Comparing Traces section. 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied whenever you open a new Trace 
Browser or Viewer . 

Tools Menu 
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The Help menu for the Trace Browser contains the following 
options: 

 

Figure 2-28.  Trace Browser – Help menu 

Option Description 

Trace Viewer 
Help 

Opens Envision Help to the Trace Browser 
and Viewer page. 

About Trace 
Viewer 

Displays the version number of your 
Envision installation. 

Help Menu 
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The Trace Browser and Trace Viewer panes contain two toolbars: 

• Standard toolbar 

• Display toolbar 

The buttons on these toolbars provide standard navigation 
features and easy access to the Trace Browser and Trace Viewer 
menu options. 

To show or hide these toolbars, right-click in the toolbar area at 
the top of the Trace Browser pane, and then choose the required 
toolbar. 

The Standard toolbar contains the following buttons by default: 

Button Description 

 Remove 
Current 
Trace 

Removes the selected trace from the 
display and the Legend. 

This option is designed for the Trace 
Viewer, which can show multiple 
traces. 

 Remove All 
Traces 

Removes all traces from the Trace 
Browser pane and the Legend. 

 Print Opens a standard Print dialog box, 
allowing you to select the printer to 
which the trace will be sent. 

Trace Browser Toolbars 

Standard Toolbar 
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The Display toolbar contains the following buttons by default: 

Button Description 

 Autoscale Rescales the display so that the data 
points and peak labels fit into the 
display completely. 

 Autoscale – X 
only 

Rescales the display such that the X 
axis fits into the display completely. 

 Autoscale – Y 
only 

Rescales the display such that the Y 
axis and peak labels fit into the display 
completely. 

 Zoom In Rescales the display to zoom in 10% 
around the current position of the 
crosshairs (whether or not they are 
actually visible). 

 Zoom Out Rescales the display to zoom out 10% 
around the current position of the 
crosshairs (whether or not they are 
actually visible). 

 Undo last 
zoom 

Returns to the previous screen. This 
action may be repeated to go back 
several screens. 

 Paged 
(display 
mode) 

Shows only one trace array in the 
Trace Browser. 

See the Viewing Multiple Traces in a 
Window section. 

 Overlaid 
(display 
mode) 

Overlays all open trace arrays in the 
Trace Browser. 

See the Viewing Multiple Traces in a 
Window section. 

Display Toolbar 
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Button Description 

 Stacked 
(display 
mode) 

Shows all open trace arrays stacked in 
the Trace Browser. 

See the Viewing Multiple Traces in a 
Window section. 

 Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. 
By default, all low values display to the 
left, with high values to the right. 

 Normalize Y Normalizes the Y data points from 0 to 
1. 

When you select this option, a warning 
message appears to advise you that 
peak label information cannot be 
shown in normalized display. If you 
choose to continue, peak labeling is 
turned off. 

 Go to the 
next data 
point 

Navigates to the next data point, to the 
right of the current position of the 
crosshairs. 

 Go to the 
Previous data 
point 

Navigates to the previous data point, 
to the left of the current position of the 
crosshairs. 

Note The Zoom and Autoscale features affect the display of all 
loaded data if the display is set to either the stacked or overlaid 
mode. ▲ 
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When you right-click in the Trace Browser pane, the shortcut 
menu that appears contains commonly-used options from the 
Trace Browser’s menu and toolbar:  

 

Figure 2-29.  Trace Browser shortcut menu 

See the Trace Browser Menus and Trace Browser Toolbars 
sections. 

You can set the trace display limits manually.  

To set the trace display limits manually: 

1. Select Display > Set Display Limits from the Trace Browser 
menu. 

The Set Limits dialog box appears: 

 

Figure 2-30.  Set Limits dialog box 

2. Enter the start and end points for the X and Y display limits, 
and then click OK to save them. 

Trace Browser Shortcut 
Menu 

Setting the Trace Display 
Limits 
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The display modes available from the Display menu allow you to 
view multiple traces in one Trace Viewer. Envision automatically 
assigns a line color to each trace in the display.  

This functionality is designed for the Trace Viewer which, unlike 
the Trace Browser, can show multiple traces. 

The following options are available: 

• Paged display mode  shows only one trace array in the 
trace display at a time, even if multiple traces are open. You 
can page through all traces sequentially using the arrow keys. 

• Overlaid display mode  overlays all open trace arrays in the 
trace box. Some traces may not be seen if they are outside the 
currently set X and Y limits. 

• Stacked display mode  shows all open trace arrays stacked 
in the trace box. The trace box is divided vertically into 
equally sized regions with each trace array in a separate 
region. 

Viewing Multiple Traces 
in a Window 
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By default, the Trace Browser labels peaks using the same text as 
their elements in the File Navigator: 

• Peaks are marked with a label and an indicator line 
connecting the label to the peak position. 

• Peak labels are displayed with vertical orientation. 

• Peak baselines are displayed as black lines with small vertical 
bars at each endpoint. 

If there are multiple peak tables for a single trace array, the first 
table is used by default to mark peaks.  

To change the peak labels, select a new label type from the 
Display menu’s Peak Labels sub-menu: 

 

Figure 2-31.  Peak Labels menu 

This menu is also available from the Trace Browser’s shortcut 
menu. A check mark indicates the current peak labeling option. 

Note The Peak Labels menu updates when you switch between 
trace arrays. ▲ 

Trace View Peak 
Labeling 
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You can set trace display options, such as showing crosshairs and 
partition lines, and active trace settings such as line properties. 

To change the trace display options, select Tools > Options from 
the Trace Browser menu. The Trace Viewer Options window 
appears:  

 

Figure 2-32.  Trace Viewer Options window 

The Display Settings section contains the following options: 

Option Description 

Show cursor 
crosshairs 

Shows crosshairs on the trace display at the 
position of the last mouse click. The X and Y 
values of the mouse click position are 
indicated by the intersection of the 
crosshairs, and are labeled on the appropriate 
axis. 

You can double-click in the trace display to 
move the cursor crosshairs to the data point 
closest to the mouse click. 

Show 
partition lines 
in stacked 
mode 

Shows a black partition line at the lowest Y 
value in each trace array’s section in the 
stack. 

Setting the Trace Display 
Options 
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Option Description 

Show peak 
warning for 
normalized Y 
mode 

When in normalized Y mode, shows a 
warning dialog indicating that peak labels 
and indicators are not displayed. 

Note The Display Settings options are selected by default. 
Clear the check boxes to turn the settings off. ▲ 

The Active Trace Settings section contains the following options: 

Option Description 

Automatic 
scaling when 
the active trace 
changes 

Autoscales the trace display in the X and Y 
directions each time the active trace 
changes.  

This option is deselected by default. 

Automatic X 
axis orientation 
when the 
active trace 
changes 

Automatically orients the trace display based 
on the axis unit of the active trace.  

This option is deselected by default. 

Show Active 
Trace using 
specified line 
properties 

Shows the active trace array using the line 
color, style, and width specified using the 
Line Properties button. 

Envision applies the specified line properties 
to whichever trace is currently active; when 
you select a new trace, its line changes to use 
the specified color, style and width. 

Note This overrides the line properties set 
for each trace using the Trace Browser’s 
Display > Active Trace > Line Properties 
menu option. See Changing a Trace’s Line 
Properties. ▲ 
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Option Description 

Line Properties 
button 

Opens the Line Properties dialog box: 

 

Figure 2-33.  Line Properties dialog box 

You can change the line color, style, and 
width used for the active trace.  

Click OK to save changes and return to the 
Trace Viewer Options window. Envision 
selects the “Show Active Trace using 
specified line properties” check box 
automatically. 
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You can change the line color, style, and width used for a trace in 
the current Trace Browser or Trace Viewer window. 

To change a trace’s line properties: 

1. Select the trace in the Legend pane. 

2. Select Display > Active Trace > Line Properties from the 
Trace Browser’s menu. 

The Line Properties dialog box appears: 

 

Figure 2-34.  Line Properties dialog box 

Note You can also access the Line Properties option from 
the shortcut menu that appears when you right-click the trace 
in the Trace Browser’s Legend. ▲ 

3. Specify the line color, style, and width for the selected trace.  

4. Click OK to save the changes.  

The specified line properties are used for the selected trace in 
the current Trace Browser or Trace Viewer window: 

• If you open the trace in another window, its default line 
properties will be used. 

• When the trace is active, its line properties may be 
overridden by those specified in the Trace Viewer 
Options window’s Active Trace Settings. See Setting the 
Trace Display Options. 

Changing a Trace’s Line 
Properties 
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You can change the label applied to a trace using the Edit User 
Label dialog box. 

To change a trace’s display label: 

1. Select the trace in the Legend pane. 

2. Select Display > Active Trace > User Label from the Trace 
Browser’s menu. 

The Edit User Label dialog box appears: 

 

Figure 2-35.  Edit User Label dialog box 

Note You can also access the User Label option from the 
shortcut menu that appears when you right-click the trace in 
the Trace Browser’s Legend. ▲ 

3. Enter the name to appear in the Legend for the selected trace.  

4. Click OK to save the changes.  

Changing a Trace’s 
Display Label 
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When comparing traces from different sources and the traces have 
different units, you can apply a unit conversion to compare traces 
on the same scale. 

This functionality is not available in the Trace Browser, which 
cannot show multiple traces. 

In the following example, we demonstrate this functionality by 
applying it to the X-axis units to compare two traces: 

1. In the Trace Viewer, open a trace.  

In the following example trace, the units on the X and Y axes 
are Arbitrary, common for ASCII data. 

 

Figure 2-36. Trace Viewer containing trace with Arbitrary units 

2. You can set Arbitrary units to any available units: 

a. Right-click on the trace entry in the Legend. 

b. Select Arbitrary X Unit, and select a unit from the list.  

Alternatively, you use the Unit Display Configuration 
window, by selecting Tools > Unit Display Configuration 
from the Trace Viewer menu bar. 

Applying Unit 
Conversions for 

Comparing Traces 
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For this example, set the X Axis unit to Seconds. If the Apply 

default unit conversions button  is off, click to turn it 
on to see the change in the label on the X axis. 

3. To compare the current trace with another trace, open 
another trace file and drag it from the File Navigator into the 
Trace Viewer.  

4. To see the traces together, click Overlay Traces or Stack 
Traces.  

For this example, overlay the traces. 

5. If there is a difference in Y units, click the Normalize the Y 
data points button . 

In this example, the new trace has X units in Minutes. Note 
that the overlaid traces have a “Unit Mismatch” noted on the 
X-axis. This mismatch causes the second trace (blue line) to 
be compressed at the left edge of the Trace Viewer. 

 

Figure 2-37. Trace Viewer containing two traces with 
normalized Y units 
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6. To compare the mismatched traces on the same X scale: 

a. Open the Unit Display Configuration window (Tools > 
Unit Display Configuration) 

b. Set the Time units to Seconds, and click Apply.  

Both traces are now using the same scale. Note that the 
legend contains columns for both X Unit (this is the original 
unit), and X Unit (Displayed), so that you can easily check 
the original units against the converted units. 

 

Figure 2-38. Trace Viewer with both traces converted to display 
in seconds on the X axis 
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When working in a Trace Viewer, you can select Tools > Unit 
Display Configuration to open the Unit Display Configuration 
window. This window controls the units used for traces open in 
the viewer: 

 

Figure 2-39. Unit Display Configuration window 

You can use the Unit Display Configuration window to: 

• Change the unit display on the X axis, the Y axis, or both 
axes. 

On the X-axis, you can select the units used for time, length 
and wavenumber, frequency, and temperature.  

On the Y-axis, you can select the units used for voltage, 
temperature, and mass, as well as spectroscopic units such as 
transmission and reflectance. 

Unit Display Configuration 
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• Select a unit for Arbitrary or Unknown units. 

Many traces do not have units assigned and appear as 
“Unknown.” In these cases, select a unit from the list to be 
used instead. 

• Save the selected unit as the default unit. 

The settings you make here are saved and used when you 
open new Trace Browser windows. 

Click Apply to save any changes you make in the Unit Display 
Configuration window.  

For an example that uses the features of this window, see the 
Applying Unit Conversions for Comparing Traces section. 
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The Parameter Browser displays parameters, derived properties, 
and element and attribute values for any element in the GAML 
hierarchy.  

The Parameter Viewer shares the same functionality as the 
Parameter Browser, but only updates when you send parameters 
to it. 

 

Figure 2-40.  Parameter Browser 

The data grid shows data in the following columns: 

• Name (hidden by default) 

• Alias (hidden by default) 

• Label  

• Value 

• Group 

Note The Parameter Browser’s grid clears whenever new data is 
loaded. When the active element has no parameters, the 
Parameter Browser appears blank. ▲ 

Parameter Browser 
and Viewer 
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Each column in the grid can be toggled on or off by selecting the 
corresponding item in the Parameter Browser’s View menu.  

You can also toggle columns from the Parameter Browser’s 
shortcut menu, which appears when you right-click within the 
data grid. The shortcut menu also includes a Close option, which 
closes the Parameter Browser. 

The functionality described in this section, while labeled for the 
Parameter Browser, also applies to the Parameter Viewer.  

This section describes the menu options at the top of the 
Parameter Browser and Parameter Viewer panes. 

The File menu for the Parameter Browser contains the following 
options: 

 

Figure 2-41.  Parameter Browser – File menu 

Option Description 

Export current 
table to file 

Exports the currently displayed table 
(including hidden columns) to a tab-
delimited text file. A standard Save dialog 
box appears. 

Export current 
table to 
clipboard 

Exports the currently displayed table 
(including hidden columns) to a tab-
delimited text file. A standard Save dialog 
box appears. 

Parameter Browser Menu 

File Menu  
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Option Description 

Export all 
parameters to 
file 

Exports all parameters (including hidden 
columns) to a tab-delimited text file. A 
standard Save dialog box appears. 

Element 
Properties 

Displays the properties of the current 
elements. These properties include the 
specific values of elements and attributes as 
well as some derived properties.  

Close Closes the Parameter Browser. 

The Edit menu for the Parameter Browser contains the following 
option: 

 

Figure 2-42.  Parameter Browser – Edit menu 

Option Description 

Copy Copies the currently selected data to the 
clipboard. 

The View menu for the Parameter Browser contains standard 
options to hide or display columns and toolbars: 

 

Figure 2-43.  Parameter Browser – View menu 

Edit Menu 

View Menu 
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The Display menu for the Parameter Browser contains the 
following options: 

 

Figure 2-44.  Parameter Browser – Display menu 

Option Description 

Apply Filter Sets parameter filters to display specified 
data points.  

See the Filtering Data section for more 
information. 

Remove Filter Removes the applied filter. 

The Tools menu for the Parameter Browser contains the 
following option: 

 

Figure 2-45.  Parameter Browser – Tools menu 

Option Description 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

Display Menu 

Tools Menu 
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The Help menu for the Parameter Browser contains the following 
options: 

 

Figure 2-46.  Parameter Browser – Help menu 

Option Description 

Parameter 
Viewer Help 

Opens the Parameter Viewer section of the 
Envision Help. 

About 
Parameter 
Viewer 

Displays the installed version of the 
Parameter Viewer. 

The Parameter Browser and Parameter Viewer toolbars contain 
the following buttons: 

Button Description 

 Export 
current table 
to specified 
file 

Exports the currently displayed table 
(including hidden columns) to a tab-
delimited text file. A standard Save As 
dialog box appears. 

 Apply Filter Sets parameter filters to display 
specified data points.  

See the Filtering Data section for more 
information. 

 Remove Filter Removes the applied filter. 

Help Menu 

Parameter Browser 
Toolbar 
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When viewing items in the Parameter and Peak Table Browsers 
you can apply filters to display specific data points.  

To apply a filter: 

1. Click the Apply Filter button  on the Parameter Browser 
toolbar, or select Display > Apply Filter from the Parameter 
Browser menu. 

The Filter dialog box appears: 

 

Figure 2-47.  Filter dialog box 

The Filter dialog box contains information about the 
currently active cell. 

2. Select a table column for filtering from the Column list.  

3. Select an operator from the Operation list: 

• Contains (default)  

• Equals 

• Does not contain 

• Does not equal 

4. Enter a value in the Text field. Any text string can be entered 
in this field. 

5. Click OK to apply the filter. 

Note After you apply a filter, the number of rows matching the 
filter is indicated at the bottom-right of the browser. For 

Filtering Data 
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example, if the table contains 10 rows, and 4 rows match the 
filter criteria, “4 of 10 rows” appears. ▲ 

When you apply a filter, the Display > Remove Filter menu item 

and the Remove Filter button  become available.  

To remove the filter and return the display to browse mode, 
either select the Remove Filter menu option or click the Remove 
Filter button. 

You can sort the data in the Parameter Browser and Peak Table 
Browser grids into ascending or descending order by clicking on 
the column headings. An arrow located to the right of a column 
heading indicates the column used for the sort, and the order of 
the sort. 

 

Figure 2-48.  Sorted column heading example 

Removing a Filter 

Sorting Data 
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The Peak Table Browser contains information about the peaks in 
a trace. It appears when you open a new GAML file, and is also 
available from the shortcut menu for elements in the File 
Navigator. 

The Peak Table Viewer shares the same functionality as the Peak 
Table Browser, but only updates when you send data to it. 

 

Figure 2-49.  Peak Table Browser – Peak Table view 

The data grid can be displayed in the following ways:  

• Peak Table view (default) 

• Peak Parameters view 

• Peak Table Parameters view  

You can use the  icon to track a row through the three views. 

See the Peak Table Browser Display Options section for more 
information. 

Peak Table Browser 
and Viewer 
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To show or hide columns in the Peak Table Browser grid, select 
column names in the View menu. See the View Menu section for 
more information. 

Alternatively, you can right-click the grid to open a menu 
showing the available columns, with check marks beside those 
that are displayed. Click a column name to toggle its display. 

Note The default setting for the Peak Table Browser is to show 
all rows in the Peak Table view, and to show all columns except 
Name in the Peak Parameter and Peak Table Parameter Views. ▲ 

The functionality described in this section, while labeled for the 
Parameter Browser, also applies to the Parameter Viewer.  

This section describes the menu options at the top of the Peak 
Table Browser and Peak Table Viewer panes. 

The File menu for the Peak Table Browser contains the following 
options: 

 

Figure 2-50.  Peak Table Browser – File menu 

Option Description 

Export current 
table to file 

Exports the currently displayed table 
(including hidden columns) to a tab-
delimited text file. A standard Save As dialog 
box appears. 

Peak Table Browser 
Menu 

File Menu  



 The Envision User Interface 

Thermo Fisher Scientific GRAMS Envision User Guide      67 

Option Description 

Export current 
table to 
clipboard 

Copies the currently displayed table 
(including hidden columns) to the clipboard. 
Once copied, you can paste the table data to 
another application, such as a word 
processor, spreadsheet, or text editor.  

Close Closes the Peak Table Browser. 

The Edit menu for the Peak Table Browser has a single Copy 
option: 

 

Figure 2-51.  Peak Table Browser – Edit menu 

Option Description 

Copy Copies the active trace box, together with 
the trace array data, to the clipboard. 

You can also perform the Copy function by 
using CTRL+C from your keyboard. 

Edit Menu 
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The View menu for the Peak Table Browser contains the 
following options: 

 

Figure 2-52.  Peak Table Browser – View menu 

The first three options control the overall display mode for the 
Peak Table Browser: 

Option Description 

Peak Table This is the default mode for the Peak Table 
Browser. The grid contains element and 
attribute values for each peak in the peak 
table. All available columns are shown. 

See the Peak Table Browser Display Options 
section for more information. 

Peak Table 
Parameters 

In Peak Table Parameter view, the grid 
contains the following columns:  

• Name (hidden by default) 

• Label 

• Value 

• Group 

View Menu 
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Option Description 

Parameters from the peak table element are 
displayed. 

See the Peak Table Browser Display Options 
section for more information. 

Peak 
Parameters 

In Peak Parameter view, the grid can show 
peak parameters from a single peak or from 
all peaks. The grid contains the following 
columns:  

• Peak Number 

• Name (hidden by default) 

• Label 

• Value 

• Group 

See the Peak Table Browser Display Options 
section for more information. 

The rest of the View menu contains options to show or hide 
columns for each display mode, close the Peak Parameters View, 
and show or hide its toolbar and status bar. 

The Display menu for the Peak Table Browser contains the 
following options: 

 

Figure 2-53.  Peak Table Browser – Display menu 

Display Menu 
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Option Description 

Apply Filter Sets parameter filters to display specified 
data points. See the Filtering Data section 
for more information. 

Remove Filter Removes the applied filter. 

The Tools menu for the Peak Table Browser contains the 
following option: 

 

Figure 2-54.  Peak Table Browser – Tools menu 

Option Description 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

The Help menu for the Peak Table Browser contains the 
following options: 

 

Figure 2-55.  Peak Table Browser – Help menu 

Option Description 

Peak Table 
Viewer Help 

Accesses the Peak Table Viewer section of 
the Envision Help. 

About Peak 
Table Viewer 

Displays the installed version of the Peak 
Table Viewer. 

Tools Menu 

Help Menu 
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The Peak Table Browser and Peak Table Viewer toolbars contain 
the following buttons: 

Button Description 

 Export 
current table 
to specified 
file 

Exports the currently displayed table 
(including hidden columns) to a tab-
delimited text file. A standard Save As 
dialog box appears. 

 Apply 
Filter… 

Set parameter filters to display 
specified data points.  

See the Filtering Data section. 

 Remove Filter Removes the applied filter. 

 Peak Table Displays the Peak Table view. 

See the Peak Table View section. 

 Peak Table 
Parameters 

Displays the Peak Table Parameters 
view.  

See the Peak Table Parameters View 
section. 

 Peak 
Parameters 

Displays the Peak Parameters view.  

See the Peak Parameters View section. 

The Peak Table Browser and Peak Table Viewer have three 
different display modes: 

• Peak Table 

• Peak Table Parameters 

• Peak Parameters 

A description of each of these options follows.  

Peak Table Browser 
Toolbar 

Peak Table Browser 
Display Options 
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Peak Table view is the default mode for the Peak Table Browser. 
The table contains element and attribute values for each peak, 
using the following columns: 

• Peak Number 

• Peak Name 

• Peak X Value 

• Peak Y Value 

• Group 

• Baseline Start X 

• Baseline Start Y 

• Baseline End X 

• Baseline End Y 

 

Figure 2-56.  Peak Table Browser – Peak Table view 

Peak Table View 
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You can click the  or  icon, to the left of each row, to expand 
or collapse each peak’s details, providing a hyperlink to its 
parameters: 

 

Figure 2-57.  Expanded peak in the Peak Table view 

The hyperlink opens the Peak Parameters view for that peak: 

 

Figure 2-58.  Peak Parameters for an individual peak 

The top row contains the information from that peak’s row in the 
peak table. Below is a table of all the parameters for that peak and 
their values. You can click the Back button  to return to the 
Peak Table view. 

You can sort the data in the grid in ascending or descending 
order, as well as applying filters. See Sorting Data and Filtering 
Data. 
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In Peak Table Parameters view, the grid contains the following 
columns:  

• Name (hidden by default): The name of the parameter. 

• Alias: The alias of the parameter (if one exists). 

• Label: The label of the parameter. This is usually similar to 
the Name. 

• Value: The value for the parameter as given in the data file. 

• Group: An identifier to help with organizing data. 

 

Figure 2-59.  Peak Table Viewer – Peak Table Parameters view 

Right-click within the Peak Table Parameters view to open a 
shortcut menu from which you can select columns to be seen or 
hidden. Visible columns are indicated by checkmarks: 

 

Figure 2-60.  Column selection menu in the Peak Table Viewer 

You can sort the data in the grid in ascending or descending 
order, as well as applying filters. See Sorting Data and Filtering 
Data. 

Peak Table Parameters View 
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In Peak Parameters view, the grid can show peak parameters from 
a single peak or all peaks. The column names in this view are the 
same as those found in the Peak Table Parameters View, with the 
additional column, Peak Number. Peaks in a trace are generally 
numbered sequentially from left to right.  

 

Figure 2-61.  Peak Table Viewer – Peak Parameters view 

When the Peak Parameter view is opened from the View menu or 
the toolbar button, parameter information for all peaks appears, 
allowing data comparison of multiple peaks. When opened via 
the Peak Parameters hyperlink (see Figure 2-57), only parameters 
from that single peak are shown. 

You can sort the data in the grid in ascending or descending 
order, as well as applying filters. See Sorting Data and Filtering 
Data. 

Peak Parameters View 
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The Main window opens with three browser windows:  

• Trace Browser 

• Parameter Browser 

• Peak Table Browser 

In addition to these, you can open corresponding viewers: 

• Trace Viewer 

• Parameter Viewer 

• Peak Table Viewer 

Browsers and viewers differ in that when you scroll through the 
File Navigator, a browser updates to show the information for 
that trace. In a viewer, you must drag a different trace from the 
File Navigator in order to update the view. 

When opening a viewer, the name on its tab is suffixed with a 
number indicating the order in which it was opened. 

Note The exception is the HTML Viewer, which does not use a 
numeric suffix. ▲ 

To open a new viewer: 

1. Select a trace in the File Navigator. 

2. Right-click and select Display from the shortcut menu that 
appears. 

3. Select a viewer from the Display menu. 

Alternatively, select Display from the main menu, and then select 
a viewer from the Display menu options. 

Note Some menu options may be unavailable, depending on 
the data that the selected trace contains. ▲ 

Opening Additional 
Views 
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The HTML Viewer allows you to open URLs and retrieve files 
from a Web-based application or search tool.  

There are two ways to open the HTML Viewer: 

• Click on the HTML Viewer button  on the Main toolbar 
at the top of the Envision interface. 

• Select File > Open HTML Viewer from the main menu. 

The HTML Viewer also appears when Envision starts in Demo 
Mode. 

The HTML Viewer window opens with the default home page: 

 

Figure 2-62.  HTML Viewer 

Note For information about specifying the default home page, 
see the Setting Envision Options section. ▲ 

HTML Viewer 
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You can enter URLs into the HTML Viewer’s Address field: 

 

Figure 2-63.  HTML Viewer – Address field 

You can use Envision’s command line syntax to automate 
opening URLs in the HTML Viewer. This allows a program, 
such as a LIMS system, to open a URL and pass parameters to a 
Web application, which can in turn provide a link to a file that 
can be selected, downloaded and viewed directly in Envision. 

For more details see Appendix A, Command Line Syntax. 

This section describes the menu options at the top of the HTML 
Viewer. 

The File menu for the HTML Viewer has the following options: 

 

Figure 2-64.  HTML Viewer – File menu 

Option Description 

Open Opens the Enter URL dialog box, in which 
you can enter a URL.  

Print Sends the web page to the printer. A 
standard Print dialog box appears. 

HTML Viewer Menu 

File Menu  
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Option Description 

Print Preview Opens a standard Print Preview window, 
where you can modify page properties prior 
to printing. 

Close Closes the HTML Viewer. 

The View menu for the HTML Viewer contains a single Toolbar 
menu option. Use this option to hide or show the HTML Viewer 
toolbar. 

The Help menu for the HTML Viewer has the following options: 

 

Figure 2-65.  HTML Viewer – Help menu 

Option Description 

HTML 
Viewer Help 

Opens the HTML Viewer section of the 
Envision Help in a new window. 

About HTML 
Viewer 

Displays the installed version of the HTML 
Viewer. 

View Menu  

Help Menu 
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In addition to the Address field, the HTML Viewer toolbar 
contains the following buttons: 

Button Description 

 Back Navigates to the previous Web page. 

 Forward Advances to the next Web page. 

 Refresh Refreshes the current Web page. 

 Print Sends the Web page to the printer. A 
standard Print dialog box appears. 

 Print 
preview 
document 

Opens a standard Print Preview 
window, where you can modify page 
properties prior to printing. 

 Go Navigates to the URL specified in the 
Address field. 

 Close Closes the HTML Viewer. 

 

HTML Viewer Toolbar 
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The Linked Data Viewer uses the link element within a GAML 
file to show related (linked) traces in a meaningful way. The 
viewer supports data such as GC-MS, LC-MS, and GC-IR: 

 

Figure 2-66.  Linked Data Viewer 

To display the Linked Data Viewer, select Display > New Link 
Viewer from the Main menu. 

The linked data module receives a parent trace and then looks for 
a child trace with a corresponding link indicator. This data 
appears in two trace boxes: 

• The parent trace is displayed in the top trace box. 

• The child trace is displayed in the lower trace box. 

Only one trace box can be considered the active trace box at any 
given time. Any actions performed apply to this trace box. 

Note The child trace must be within the same experiment as 
the parent trace. ▲ 

Linked Data Viewer 
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Each trace box is labeled with text indicating the trace array that 
is displayed, and matches the text from the Workspace pane. The 
traces are autoscaled independently when loaded. 

To resize the trace boxes vertically, click and drag the splitter bar 
between them. The pointer changes to a splitter  when it is 
over this bar. 

You can double-click on any part of the parent trace box to 
display the trace array of the child trace. The axis labels 
correspond to the X and Y data label attributes for the displayed 
traces. If a label does not exist, the unit attribute is used. 

This section describes the menu options at the top of the Linked 
Data Viewer. 

The File menu for the Linked Data Viewer contains the following 
options: 

 

Figure 2-67.  Linked Data Viewer – File menu 

Option Description 

Page Setup Opens a standard Page Setup dialog box, 
which can be used to adjust the page settings 
prior to printing. 

Print Preview Opens a standard Print Preview window, 
where you can modify page properties prior 
to printing. 

Print Sends the current data to the printer. A 
standard Print dialog box appears. 

Close Closes the Linked Data Viewer. 

Linked Data Viewer Menu 

File Menu  
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The Edit menu for the Linked Data Viewer displays the following 
options: 

 

Figure 2-68.  Linked Data Viewer – Edit menu 

Option Description 

Undo Last 
Zoom 

Undoes the last zoom or autoscale operation. 

Copy Copies the currently selected data to the 
clipboard. 

The View menu for the Linked Data Viewer displays a single 
Toolbar option that toggles the display of the Linked Data 
Viewer toolbar. 

The Display menu for the Linked Data Viewer has the following 
options: 

 

Figure 2-69.  Linked Data Viewer – Display menu 

Edit Menu 

View Menu 

Display Menu 
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Option Description 

Autoscale Rescales the display such that the data points 
and peak labels fit into the display 
completely. 

Autoscale – X 
only 

Rescales the display such that the X axis fits 
into the display completely. 

Autoscale – Y 
only 

Rescales the display such that the Y axis and 
peak labels fit into the display completely. 

Zoom In Rescales the display to zoom in 10% around 
the current position of the crosshairs 
(whether or not they are actually visible). 

Zoom Out Rescales the display to zoom out 10% 
around the current position of the crosshairs 
(whether or not they are actually visible). 

Set Display 
Limits 

Opens the Set Limits dialog box, in which 
you specify the limits for the X and Y axes. 

See the Setting the Trace Display Limits 
section for more information. 

Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. Low 
values are displayed to the left, with high 
values to the right. This orientation can be 
saved as the default. 

Peak Labels Opens a submenu with the following 
options: 

 

Figure 2-70.  Peak Labels menu 
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Option Description 

 Select an option to change the peak labels. 

Refer to the Linked Data View Peak 
Labeling section for more information. 

Go to 
Previous data 
point 

Navigates to the previous data point of the 
active trace. 

The function is the same as double-clicking 
near the data point to the immediate left of 
the current position of the crosshairs. 

Go to Next 
data point 

Navigates to the next data point of the active 
trace. 

The function is the same as double-clicking 
near the data point to the immediate right of 
the current position of the crosshairs. 

Peak Table Choose from available peak tables for a trace 
array. Each peak table is listed with its name 
attribute (or the default string used in the 
File Navigator). A check mark indicates the 
selection made. By default, the first peak 
table is selected. This menu item changes for 
each active trace array and may be 
unavailable if there are no peak tables 
associated with the active trace array. 
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The Tools menu for the Linked Data Viewer contains the 
following options: 

 

Figure 2-71.  Linked Data Viewer – Tools menu 

Option Description 

Options Opens the Linked Data Viewer Options 
window. See the Setting the Linked Data 
Viewer Options section. 

Save Current 
Settings as 
Default 

Saves the current settings so that they are 
applied to each new Linked Data Viewer 
window. 

The Help menu for the Linked Data Viewer contains the 
following options: 

 

Figure 2-72.  Linked Data Viewer – Help menu 

Option Description 

Linked Data 
Viewer Help 

Accesses the Linked Data Viewer section of 
the Envision Help. 

About Linked 
Data Viewer 

Displays the installed version of the Linked 
Data Viewer. 

Tools Menu 

Help Menu 
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The Linked Data Viewer toolbar contains the following buttons: 

Button Description 

 Autoscale Rescales the display such that the data 
points and peak labels fit into the 
display completely. 

 Autoscale – X 
only 

Rescales the display such that the X 
axis fits into the display completely. 

 Autoscale – Y 
only 

Rescales the display such that the Y 
axis and peak labels fit into the display 
completely. 

 Zoom In Rescales the display to zoom in 10% 
around the current position of the 
crosshairs (whether or not they are 
actually visible). 

 Zoom Out Rescales the display to zoom out 10% 
around the current position of the 
crosshairs (whether or not they are 
actually visible). 

 Undo last 
zoom 

Returns to the previous screen. This 
action may be repeated to go back 
several screens. 

 Reverse X axis 
orientation 

Flips (reverses) the X axis orientation. 
All low values are displayed to the left, 
with high values to the right. This 
orientation can be saved as the default. 

 Go to the 
next data 
point 

Navigates to the next data point, to the 
right of the current position of the 
crosshairs. 

 Go to the 
Previous data 
point 

Navigates to the previous data point, 
to the left of the current position of the 
crosshairs. 

Linked Data Viewer 
Toolbar 
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By default, the Linked Data Viewer labels peaks using the same 
text as their elements in the File Navigator: 

• Peaks are marked with a label and an indicator line 
connecting the label to the peak position. 

• Peak labels are displayed with vertical orientation. 

• Peak baselines are displayed as black lines with small vertical 
bars at each endpoint. 

If there are multiple peak tables for a single trace array, the first 
table is used by default to mark peaks.  

To change the peak labels, select a new label type from the 
Display menu’s Peak Labels submenu: 

 

Figure 2-73.  Peak Labels menu 

This menu is also available from the Linked Data Viewer’s 
shortcut menu. A check mark indicates the current peak labeling 
option. 

Note The Peak Labels menu updates when you switch between 
trace arrays. ▲ 

Linked Data View Peak 
Labeling 
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The display options for the Linked Data Viewer can be changed 
if required.  

To set the display options select Tools > Options from the 
Linked Data Viewer menu. The Linked Data Viewer Options 
dialog box appears: 

 

Figure 2-74.  Linked Data Viewer Options dialog box 

The following options are available, and are selected by default: 

Option Description 

Show cursor 
crosshairs 

 

When selected, crosshairs appear at the 
position of the last mouse click for the 
trace.  

The X and Y values label the appropriate 
axis. Double-click on any point in the 
trace to move the crosshairs to the data 
point closest to the mouse click. 

Automatic X axis 
orientation when 
trace changes 

When selected, the trace box orients the 
X axis based on the default orientation of 
the axis unit of the active trace. 

Setting the Linked Data 
Viewer Options 
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The Report Viewer can invoke report methods created using the 
XML-based Blaise Inform reporting system.  

 

Figure 2-75.  Report Viewer 

Blaise Inform is a drag-and-drop reporting system that can be 
used with GRAMS Suite data. Coupled with the Smart Convert 
facility of Envision, you can apply standardized reports to data 
originating from multiple instrument vendors.  

Blaise Inform Report Designer is a visual tool for setting up these 
reports, which can be purchased separately. For details see: 

http://www.thermoscientific.com/grams  

Report Viewer 

http://www.thermoscientific.com/grams
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To access the Report Viewer: 

1. Do one of the following: 

• Select Report > Browse Report Method from the Main 
menu. 

• Right-click in the File Navigator and select Report > 
Browse Report Method from the shortcut menu. 

• Right-click the Holding Area icon, or an individual item 
in the Holding Area, and select Browse Report Method 
from the shortcut menu. This option can be used to send 
multiple GAML files to a single report template. See the 
Holding Area section for more details.  

2. A standard Open dialog box appears, containing a list of 
available template .irm (Inform Report Method) files. 

3. Select a report method and click Open. 

You can also select method files from the Most Recently Used 
list, which appears when you select Report from the Main menu. 

 

Figure 2-76.  Report menu – Most Recently Used list 

To add a report to this list you must open it once. 
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The Report Viewer toolbar contains the following buttons and 
features: 

Feature Description 

 Print Opens a standard Print dialog box. 

 Copy Copies the current page of the report 
to the Windows clipboard. 

 First page Navigates to the first page of the 
report. 

 Previous page Navigates to the previous page of the 
report. 

 Next page Navigates to the next page of the 
report. 

 Last page Navigates to the last page of the report. 

 Shows the current page number and 
the total number of pages in the report. 

 Zoom In Increases the size of the display. You 
can also zoom in by double-clicking 
within the Report Viewer. 

 Zoom Out Reduces the size of the display. 

 

Controls the display size. 

 Close Closes the Report Viewer. 

Report Viewer Toolbar 
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You can drag a new GAML file onto the Report Viewer window 
to re-execute the report method with new data. 

The following images show examples of different Report Viewer 
displays: 

 

Figure 2-77.  Report Viewer example – Multiplot   

 

Figure 2-78.  Report Viewer example – Raman  

Viewing New Data 
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Figure 2-79.  Report Viewer example – NMR Data  
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The GAML 3D Viewer provides a 3-dimensional view of a 3D 
trace. You can choose different display and surface styles.  

To open the GAML 3D Viewer, select Display > GAML 3D 
Viewer from the Main menu. In order for this option to be 
available, you must have a trace node that contains 3D data 
selected in the File Navigator.  

The initial view in the GAML 3D Viewer is a surface plot of the 
selected data: 

 

Figure 2-80.  GAML 3D Viewer 

Note This viewer is an example of Envision’s extensibility. It is 
a plug-in that hosts an OCX control, which is capable of 
receiving data as defined in [Envision installation 
folder]\plugins\plugins.xml. A Software Developer Kit for the 
definition of Envision plug-ins is available by request to Thermo 
Fisher Scientific. ▲ 

GAML 3D Viewer 
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Across the top of the GAML 3D Viewer is a set of menu options: 

• Home Display – Returns to the initial display (undoes 
previous zoom or rescaling actions). 

• Display Style – Selects from contour and surface map 
options. 

• Surface Style – Selects from the several options available for 
viewing surface plots. 

• Cursor Mode – Determines the behavior of the mouse when 
viewing plots. 

• AutoScale – Determines the plot scaling for the axes you 
choose. This option is only available when viewing 3D data as 
contour plots. 

• Swap X and Z – Plots X data on the Z-axis and Z data on the 
X-axis. The resulting image is similar to rotating the plot 90 
degrees clockwise. This function can be useful when using 
AutoScale options. 

GAML 3D Viewer Menu 
Options 
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Use the Display Style options for selecting a plot type for 3D 
data. 

Option Description 

Contour Map 
as Lines 

Plots 3D data with contours as discrete lines: 

 

Contour Map 
Filled Colors 

Plots 3D data with contours as a continuous 
color gradient: 

 

3D Surface 
Plot 

Plots 3D data as a three-dimensional surface 
plot:  

 

The default rendering uses a color gradient. 
See the Surface Style section for more display 
options. 

Display Style 
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Use the Surface Style options to change the appearance of 3D 
surface plots. 

Option Description 

Shows 
contour-level 
color gradient 

Displays surface plots using color gradient 
contours: 

 

This is the default surface style. 

Shows 
contour-level 
color bands 

Displays surface plots using discrete color 
bands: 

 

Draws 
isometric 
contour lines 

Uses colored lines to indicate individual 
contours on the surface plot: 

 

Surface Style 
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Option Description 

Draws only 
vertex points 

Plots only individual data points for the 
surface plot: 

 

Draws a solid 
surface 

Displays surface plots without any contours: 

 

Draws 
polygon 
outlines 
(Wirefilled) 

Displays surface plots without any contours, 
overlaid with a grid to enhance the display of 
the surface shape: 
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Option Description 

Draws 
polygon 
outlines 
(Wireframe) 

Displays surface plots using only a grid 
outline: 

 

Note When you zoom in on a surface plot, you can move the 
plot through the viewer by moving the mouse pointer close to the 
plot edge. The pointer changes to an arrow, such as . Click the 
arrow to scroll through the plot. ▲ 

To view 3D data most effectively, Envision provides several 
options to control position, rotation, and level of zoom using the 
mouse. 

Option Description 

Fly Click and hold down the mouse button to 
continuously zoom in on the plot.  

Move the mouse left, right, up, and down to 
modify the plot orientation while zooming. 

Move Use the mouse to adjust the horizontal and 
vertical position of the plot within the 3D 
viewer.  

Rotate Click the plot to establish an axis of rotation, 
and move the mouse around to change the 
plot orientation in three dimensions.  

Cursor Mode 
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Option Description 

Zoom Move the mouse up and down to zoom the 
plot in and out, respectively.  

Move the mouse from side to side to rotate 
the plot around the Z axis. 

When viewing 3D data as a contour plot, the AutoScale menu 
becomes available. Use the options on this menu to control 
scaling in any axis or combination of axes.  

For example, if you have zoomed in on an area of a plot, but 
would like to see the range of data in X and Z, while keeping the 
current Y scale fixed, select “XZ only” from the menu.  

The following AutoScale options are available: 

• All (XYZ) 

• X only 

• Y only 

• Z only 

• XY only 

• XZ only 

• YZ only 

AutoScale 
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The Workspace pane is located at the bottom of the Envision 
user interface. It contains the currently active data. Elements or 
sub-elements may be visible in the Workspace pane depending on 
the browser or viewer to which the data has been sent.  

Each open browser or viewer has a separate entry in the 
Workspace list. When new data is added, the list expands to 
reflect any changes. 

 

Figure 2-81.  Workspace pane 

The icon preceding an element’s description indicates that 
element’s type. The description matches the text in the File 
Navigator for the element. 

Data appears in the Workspace pane after it has been opened in a 
viewer, processor, reporting tool, or dragged to the Holding Area. 

The Holding Area is a reservoir of data for future use and always 
appears as the first entry in the Workspace list.  

To populate the Holding Area: 

• Drag items from the File Navigator pane by highlighting 
them and then holding down the left mouse button. 

• Right-click items in the File Navigator pane and select Send 
to Holding Area from the shortcut menu. 

Workspace Pane 

Holding Area 
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• Close a window, such as a Parameter Viewer, in which case 
the contained node is moved to the Holding Area.  

This behavior is controlled by the Workspace Settings on the 
Options window. See the Setting Envision Options section.  

The Holding Area can be used to group items together for 
reporting purposes. This enables you to send multiple GAML 
files to a single report template. 

To send multiple items to a report template: 

1. Move the items to the Holding Area, using one of the 
methods described above. 

2. Right-click the Holding Area icon  in the Workspace pane, 
and select Report > Browse Report Method from the 
shortcut menu. 

3. Select the report method from the list. 

For more information about reporting, see the Report Viewer 
section. 

Right-click on an item in the Workspace to open a shortcut 
menu: 

 

Figure 2-82.  Workspace shortcut menu 

The options available from this menu vary according to the item 
that is currently selected in the Workspace pane. 

Workspace Menu Options 
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Option Description 

Save As Saves a node of a GAML file. 

For more information, see the Using the 
Save As Option section. 

Display Accesses the Display menu options. 

For more information, see the Display Menu 
section. 

Report Accesses the Report menu options. 

For more information, see the Report Menu 
section. 

Action Accesses the Action menu options. 

For more information, see the Action Menu 
section. 

Remove from 
Holding Area 

Remove a single item from the Holding 
Area. 

Note Closing a GAML file also removes it 
from the Holding Area. ▲ 

Empty 
Holding Area 

Empties the Holding Area. All items that are 
currently displayed in the Holding Area are 
removed. 

Close Closes the file that is currently selected in the 
Workspace pane. 

You can pin, unpin, resize or close the Workspace pane as 
needed. See the Customizing the User Interface section. 
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This section describes how you can customize the Envision user 
interface to suit your individual needs. 

You can show or hide any of the features that are currently 
displayed: 

• Select or clear an item from the View option on the Main 
menu. Features currently in view are indicated by 
checkmarks.  

• Click the  button, in the top right corner of a pane, to close 
that pane. 

To resize a pane in the Envision interface, you can click and drag 
any of its edges. The pointer changes to  or . 

You can float, dock, or unpin the following elements of the 
Envision application: 

• File Navigator 

• Data Preview pane 

• Workspace pane 

• Legend 

Click the  button to unpin an interface element. The 
unpinned item is replaced by a tab on the application window, as 
shown in the following example: 

 

Figure 2-83.  Workspace pane – unpinned 

Click the mouse pointer on the tab to open the interface element 
for viewing. While open, click the element’s  button to re-pin 

Customizing the User 
Interface 

Hiding and Displaying 
Features  

Resizing Panes 

Maximizing the Viewing 
Area 
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that element to its original location in the Envision application 
window. 

Click-and-drag the title bar of a pane to “float” it above the main 
window. The window can remain floating or it can be dragged to 
a new position indicated by the blue and white docking icons, as 
shown in the following example: 

 

Figure 2-84.  Workspace pane – floating 
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You can set a number of different options for Envision. These 
options are accessed from the Options window. 

To open the Options window, select Tools > Options from the 
Main menu. 

 

Figure 2-85.  Options window 

The Options window is divided into four areas: 

• Register Application 

• Workspace Settings 

• HTML Viewer 

• GAML Integrity 

Setting Envision 
Options 
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The options in this area of the Options window control allow you 
to make Envision the default viewer for its supported file types. 

Option Description 

Set Envision as the 
default viewer for 
AnIML files 

Select this check box to make 
Envision your default viewer for 
AnIML data files, when you click 
Register. 

Register Click this button to register Envision 
as your default viewer for GAML 
files. 

If the “Set Envision…” check box is 
selected, Envision will also become 
your default viewer for AnIML files. 

Prompt users to 
register the 
application when it is 
not already registered 

Select this check box to determine, 
when Envision starts, whether it is 
the default viewer for GAML files. If 
it is not, the user will be prompted to 
register Envision as their default 
GAML file viewer. 

 

This area of the Options window contains a single check box: 

Option Description 

Add data to holding 
area when viewers 
close 

Select this check box to retain 
references to GAML entities in the 
Workspace pane’s Holding Area 
when windows containing those 
GAML entities are closed. 

Note Closing a GAML entity entirely removes its details from 
the Holding Area. ▲ 

Register Application 

Workspace Settings 
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This area of the Options window contains a single field: 

Option Description 

Home page Enter the default URL for the 
HTML Viewer. This page is opened 
every time you open an HTML 
Viewer window. 

Note When Envision is running in Demo Mode, the home 
page is restricted to the GAML website’s “Example GAML Files” 
page. ▲ 

This area of the Options window contains a single check box: 

Option Description 

Warn users of 
integrity test failures 

Select this check box to warn users 
when files do not match their internal 
checksums. 

A GAML file not matching its 
internal checksums can indicate 
unauthorized alteration to that file. 

HTML Viewer 

GAML Integrity 
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Notes 
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A. Command Line Syntax 

The following commands provide a basic automation interface 
for Envision to interact with external programs and Web services. 
A more comprehensive plug-in SDK (Software Development Kit) 
is available from Thermo Fisher Scientific. 

Command Line 
Arguments 

Description 

-wType <window 

type> 

The window type to open. Valid window 
types are: 

• GamlView2D   

• GamlParam   

• GamlPeakParm  

• GamlViewLink   

• GamlReportViewer 

• HtmlViewer 

-wNew Flag that indicates to create a new 
window. 

If flag is absent, Envision attempts to use 
an existing window. If a window of the 
appropriate window type is not already 
open, Envision opens a new window. 

-wName <window 

name> 

The name for the window. Cannot be 
used to change the names of the three 
browser windows. 
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Command Line 
Arguments 

Description 

-r <report 

method> 

For the GamlReportViewer window type 
option only. This flag indicates the 
Inform method report to use.   

For example: 

-r "c:\report1.irm" 

The –r command argument is required 
for the GamlReportViewer window type. 
It is ignored by any other window type. 

When generating reports, if multiple 
GAML files (or RAW files) are provided, 
the report method is executed on each of 
the provided GAML files. Each of these 
reports appears in its own Report Viewer 
window. 

-f <file> The GAML or RAW file to open.  

For example:   

-f "c:\data1.gaml" 

-c <converter 

name> 

The name of the converter to be used 
when a RAW data file is opened. Consult 
the Instrument Data File Converters help 
for the converter name. 

For example: 

–c AIA_CGM –f "c:\Sample.cdf" 
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Command Line 
Arguments 

Description 

-u <URL> URL to open.   

For example:   

-u "http://www.gaml.org" 

The –u command argument is required 
for the HTMLViewer window type.   
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The following are some command line examples. 

To open a single GAML file in the 2D viewer: 

Envision.exe -wType GamlView2D -wNew -wName "My Trace" -f 
"C:\data1.gaml" 

To open another GAML file in the same 2D viewer as above: 

Envision.exe -wType GamlView2D -wNew -wName "My Trace" -f 
"C:\data2.gaml" 

To create a report in a new window: 

Envision.exe -wType GamlReportViewer -wNew -wName "My Report" 
-r "c:\methods\mymethod.irm" -f "c:\data\file1.gaml" 

Examples 
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3 

3D Viewer,  95 

A 

Action menu,  16 

AnIML format,  2 

C 

Command line syntax,  111 

examples,  114 

D 

data 

filtering,  63 
sorting,  64 
viewing,  93 

Data Preview window,  27 

hiding,  29 
property preview,  29 
trace preview,  28 

Demo Mode,  4 

Display menu,  15, 37 

display mode 

changing,  32 

Display toolbar,  43 

E 

Edit menu,  36 

F 

File Converters,  2 

File menu,  8, 35 

File Navigator,  24 

hierarchy 
viewing,  25 

filters 

removing,  64 

G 

GAML 3D Viewer,  95 

Display Style menu,  96 
menu,  96 

GAML Converters,  2 

GAML files 

saving,  9, 12, 19, 104 

GAML Integrity options,  109 

GRAMS Converters,  2 

GRAMS Envision 

Demo Mode,  4 
login,  3 
starting,  3 
welcome,  1 
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H 

Help menu,  18, 41 

Holding Area,  102 

HTML Viewer,  77 

File menu,  78 
Help menu,  79 
menu,  78 
options,  109 
toolbar,  80 
View menu,  79 

I 

Instrument Data File Converters,  2 

AnIML,  2 

L 

Legend,  34 

License Failure message,  3 

Linked Data Viewer,  81 

Display menu,  83 
Edit menu,  83 
Help menu,  86 
menu,  82 
peak labeling,  88 
setting options,  89 
toolbar,  87 
Tools menu,  86 
View menu,  83 

M 

main menu,  7 

setting options,  107 

Main window,  30 

menu,  33 
Parameter Browser,  58 
Parameter Viewer,  58 
Peak Table Browser,  65 

Peak Table Viewer,  65 
toolbar,  33 
Trace Browser,  34 
Trace Viewer,  34 

Main Window menu,  33 

Main Window toolbar,  33 

menus,  7 

GAML 3D Viewer,  96 
HTML Viewer,  78 
Linked Data Viewer,  82 
Main window,  33 
Trace Browser,  35 

multiple traces 

viewing,  46 

O 

Operations toolbar,  20 

Options window,  107 

GAML Integrity,  109 
HTML Viewer,  109 
Register Applications,  108 
Workspace Settings,  108 

P 

Parameter Browser,  58 

Display menu,  61 
Edit menu,  60 
File menu,  59 
filtering data,  63 
Help menu,  62 
menu,  59 
sorting data,  64 
toolbar,  62 
Tools menu,  61 
View menu,  60 

Parameter Viewer,  58 

peak labeling,  47 

Peak Table Browser,  65 

Display menu,  69 
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display options,  65, 68, 69, 71 
Edit menu,  67 
File menu,  66 
Help menu,  70 
menu,  66 
peak parameter view,  75 
peak table parameter view,  74 
peak table view,  72 
toolbar,  71 
Tools menu,  70 
View menu,  68 

Peak Table Viewer,  65 

R 

Register Application options,  108 

Report menu,  15 

Report Viewer,  90 

toolbar,  92 

Request License window,  3 

S 

Save As menu option,  9, 12, 19, 104 

sending data to ta viewer,  33 

Standard toolbar,  19, 42 

status bar,  23 

T 

toolbars,  19 

adding buttons,  21 
HTML Viewer,  80 
Linked Data Viewer,  87 
Main window,  33 
Operations,  20 
Parameter Browser,  62 
Peak Table Browser,  71 
Report Viewer,  92 
Trace Browser,  42 

Tools menu,  17, 40 

Trace Browser,  34 

Display menu,  37 
Display toolbar,  43 
Edit menu,  36 
File menu,  35 
Help menu,  41 
menu,  35 
shortcut menu,  45 
Standard toolbar,  42 
Tools menu,  40 
View menu,  36 

Trace Browser toolbars,  42 

trace display 

changing labels,  52 
changing line properties,  51 
Legend,  34 
setting limits,  45 
unit conversions,  53 

trace display options 

setting,  48 

trace view 

peak labeling,  47 

Trace Viewer,  34 

traces 

saving,  9, 12, 19, 104 

U 

user interface,  5 

customizing,  105 
Data Preview window,  27 
File Navigator,  24 
main menu,  7 
Main window,  30 
Main Window menu,  33 
status bar,  23 
Workspace,  102 
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V 

View menu,  36 

viewing area 

maximizing,  105 

viewing modes,  32 

views 

opening,  76 

W 

Window menu,  17 

Workspace 

Holding Area,  102 
menu options,  103 

Workspace pane,  102 

Workspace Settings options,  108 
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